Application unavailable due to failure of downloading JavaScript assets
Incident Report for Knak
Postmortem

Root Cause:

During the last application build, a failure transpired while attempting to write the JavaScript assets to the S3 bucket essential for our CDN functionality. Consequently, when the deployment took place, our main application was referencing assets that were absent.

Actions:

  1. We are reordering our build sequence to ensure that the copying of assets to S3 transpires prior to the push to ECR, thereby implementing a fail-safe mechanism.
  2. We are enhancing our rollback procedure to simplify its execution for all parties, enabling headless operation.
  3. We will be reviewing and addressing observability gaps for builds, and release monitoring.
Posted Apr 05, 2024 - 13:25 EDT

Resolved
The application was unavailable from 8:16AM to 9:00AM.
Posted Apr 05, 2024 - 08:00 EDT