Duplicate emails in the listing
Incident Report for knak.
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 16:19 EDT
Identified
In fixing the duplication issue, it seems the Email Center had a number of emails that were cleared out. We're in the process of restoring all of those right now so your emails should start re-appearing in your Email Center. The duplication issue should be resolved now.

We're really sorry about the inconvenience. We will be meeting to identify what measures we can put in place to ensure this doesn't happen again.
Posted Sep 10, 2020 - 09:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2020 - 06:19 EDT
Investigating
Some emails are showing up in listings twice. We are working on resolving the issue as a top priority.
Note that this is just listing the email twice. Both items in the list point to the same email, so please don't delete a duplicate.
Posted Sep 08, 2020 - 15:00 EDT
This incident affected: Knak Builder/Enterprise.