There are currently errors saving emails and landing pages. Investigation is underway
Incident Report for knak.
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 13:11 EST
Investigating
We are currently investigating this issue.
Posted Dec 08, 2021 - 12:27 EST
This incident affected: Knak Builder/Enterprise.