PDF downloads not working

Incident Report for Knak

Resolved

This incident is resolved PDFs can be downloaded again
Posted Nov 19, 2025 - 15:16 EST

Investigating

We are currently investigating an issue of PDFs not being able to download
Posted Nov 19, 2025 - 14:35 EST
This incident affected: Knak App.