Brand Edit page not working
Incident Report for knak.
Resolved
This incident has been resolved.
Posted Oct 05, 2020 - 12:44 EDT
Investigating
There is currently an issue with being able to create and edit a brand. We are investigating this and hope to have this up and running ASAP.
Posted Oct 05, 2020 - 11:29 EDT
This incident affected: Knak Builder/Enterprise.