Issues with certain emails being able to be opened in Builder
Incident Report for knak.
Resolved
This incident has been resolved.
Posted Apr 16, 2018 - 08:54 EDT
Investigating
Issues with certain emails being able to be opened in Builder.
Posted Apr 16, 2018 - 08:50 EDT